Announcement

Collapse
No announcement yet.

Windscreen demister not demisting??

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windscreen demister not demisting??

    Hi
    Just got me a new surf again (secondhand but new to me) and on these orrible cold mornings my windscreen demist doesnt appear to be working at all. I tried everything so i now have to drive with the two front windows open a little which doesnt please my husband or the two kiddies. Any suggestions. I had a look in the fuse box under the bonnet and noticed there's a fuel/heater relay missing (not sure what this is but i've ordered one from toyota anyway) could this be the culprit? Also my last surf didnt have one of these but there's a clean air box (thingy....sound like a proper woman now dont i?) in the back on the ceiling which doesnt appear to work. Can someone please tell me what it is and how it all works please. I do know a bit about cars but this is baffling me.
    Sorry to sound like a pathetic woman but i relly need help on this one.
    Thanks guys.
    HELEN xx

  • #2
    Cancel the order for the fuel heater relay. You do not have a fuel heater. Trust me.

    Nev

    Comment


    • #3
      Look through these messages.
      Paul </Slugsie>
      Immortal.so far!

      Comment


      • #4
        Also, no idea about the clean air box thingy, never heard of one of them before. Any chance you could post a picture of it?
        Paul </Slugsie>
        Immortal.so far!

        Comment


        • #5
          Yep no probs....will post a pic later when i get home.
          Also cheers Nev wasnt sure about it, saves me 20.
          HELEN xx

          Comment


          • #6
            The clean air box thingy is, believe it or not, an air cleaner. When the switch is set to auto it will come on automatically when it senses unclean air and purify it. Try blowing smoke or something orrible at it and it will come on (i had one in my 2nd gen). Sometimes comes on when you open the windows too.
            As for your heater/ demister, does the fan come on at all or is it the window switch thats not opening the demister vents?
            If its the latter have a look behind the drivers side of the centre console and you should see the linkages that operate the fan controls. With the fan on press the window switch and see if anything moves. I had to manually push the linkage on mine to fully open demisters. Common fault apparently. Hope this helps...
            http://www.apspropertyfix.co.uk/

            Comment


            • #7
              Silly question time, is the air set to recirculate or from outside ?

              They don't seem to be too wonderful at demisting on recirc
              Look out Eastbourne, the Pandas are coming !

              Comment


              • #8
                Thanx for the info on the clean air thingy, i'll try that....as for the windscreen blower, the swith or button is showing on and the air comes out so slowly it doesnt get beyond the dash board level but the central blowers blast your head off. I'll have a good look this weekend at the whole thing and if need be i'll dismantle the dashboard to have a look.
                Also the air is set to come from outside which gives a little bit more oomph, not much though
                HELEN xx

                Comment


                • #9
                  If you get a plentiful blast from the face vents but pitiful from the windscreen vents then it's just the levers getting stuck.

                  Set the direction to anything other than demist, then look in the drivers foot-well just above the foot rest. You should see a black box with white levers on the side. Press the demist button, and you should see the levers moving, but they'll stick before they move to the demist position. Just give them a gentle push onwards and it should work fine. With a bit of practise (and long arms) you should be able to do this whilst sitting in the drivers seat.
                  Paul </Slugsie>
                  Immortal.so far!

                  Comment


                  • #10
                    Originally posted by Antshiel
                    look behind the drivers side of the centre console and you should see the linkages that operate the fan controls. With the fan on press the window switch and see if anything moves. I had to manually push the linkage on mine to fully open demisters. Common fault apparently. Hope this helps...[/COLOR]
                    Here's a pic which will help explain this. Blue line is where cable is located. Cable not assembled in this pic. Red circle is cable connection. Push this part in direction of arrow as you operate the switch. This should then open the demister vent. The cable can sometimes kink or need adjusting or the vent mechanism may need adjustment. There is a rod marked in pic which when pilled out of clip allows adjustment. Clip back in when you think it's right. They are a fiddly thing to get working just right.

                    Nev
                    Attached Files
                    Last edited by NiftyNev; 23rd October 2007, 14:32.

                    Comment


                    • #11
                      Thanks Slugsie i didnt even know that box existed (providing you arent pulling my leg lol and having a laugh at my expense hahaha), i'll check it out in a mo between my lovely old patients
                      HELEN xx

                      Comment


                      • #12
                        Heh heh, nope, not pulling your leg!

                        In the pic posted by NiftyNev I found that pushing the linkage at the bottom left so that the smaller arm turns clock-wise was the easiest way to manually operate it 'blind'.
                        Paul </Slugsie>
                        Immortal.so far!

                        Comment


                        • #13
                          Thanks for the photo, i have located it but as its quite fiddly and its a bit dirty, i will adjust it tonight if not too dark when i get indoors. Dont think my patients would appreciate me coming back into clinic covered in grey dust/dirt from car!!
                          HELEN xx

                          Comment


                          • #14
                            Originally posted by Slugsie
                            Heh heh, nope, not pulling your leg!

                            In the pic posted by NiftyNev I found that pushing the linkage at the bottom left so that the smaller arm turns clock-wise was the easiest way to manually operate it 'blind'.
                            Thanks for that mate....just managed to adjust it so the windscreen is now working good. Only thing is when you push another button for something else, they dont work. We either get windscreen or nothing. Looks like we'll have to get it fixed or adjusted to be able to operate all options. Left it on windscreen for now though.
                            Cheers for everyones help....mucho appreciation!!
                            HELEN xx

                            Comment


                            • #15
                              Hi,

                              Can you hear the motor that operates the air vent linkage arm when you press a button on the heater control?

                              Just wondering if that is the problem. The motor is located behind the centre console (just below the radio) and is awkward to get to.
                              Attached Files
                              Ian
                              One day my paranoia will go away!

                              Comment

                              Working...
                              X