Announcement

Collapse
No announcement yet.

Fuel stop solenoid for mechanical fuel pump on 1KZ/T engine

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fuel stop solenoid for mechanical fuel pump on 1KZ/T engine

    So my 1st gen runs a 3.0 diesel 1KZ/T (which was taken from a 2nd gen UK 4runner)

    The fuel stop solenoid went, and it took a lot of Googling to find correct part numbers. So I'm listing them here for reference in case anybody needs them in future

    Mechanical fuel pump

    The mechanical fuel pump number is 22100-67040 (alternative number might be 096000-8850)
    The 22100-67040 is a number given to me by Toyota
    Itís also on the actual fuel pump itself (see actual pic below)


    Fuel stop solenoid

    This is like a spill control valve on the EFI fuel pumps

    When you turn the ignition off, the plunger comes down to block the fuel so the truck stops

    It takes 12v power when ignition is on to pull a plunger out of the way so fuel can flow


    Part numbers
    - 096030-0160 was the one given to me by UK Diesel Parts based on the fuel pump number - https://www.ukdieselparts.com/
    - It appears itís pretty generic and used in tons of Toyotas and may have about a million different part numbers
    - The other ref Iíve found is 22390 6a511 (maybe also 096030-0520). This is on Milner Off Road and lots of other websites


    Hope that helps anyone who is Googling for the answer and stumbles upon this page






    Thanks
    Rob Watson (forum owner and admin)

  • #2
    Thanks
    Rob Watson (forum owner and admin)

    Comment


    • #3
      Attached is the fuel injection section from the 1KZ/T engine repair manual
      Attached Files
      Thanks
      Rob Watson (forum owner and admin)

      Comment


      • #4
        Thanks for posting this. I think I have a problem with my fuel stop solenoid on my 1st Gen 3.0 diesel. It turns over and catches a couple of times but fails to start. Have had the ECU checked and that is fine. Are these same symptoms you had?
        many thanks.
        Dave

        Comment


        • #5
          My pump is mechanical, so no ECU. Yours must be a different pump.

          The 1st gen Surf never had a 3.0 diesel in it as standard. Is yours deffo a 1st gen? What year is it, and what engine is it?
          Thanks
          Rob Watson (forum owner and admin)

          Comment

          Working...
          X