Announcement

Collapse
No announcement yet.

O/D light flashing - Require ECU fault code reading near Swindon

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • O/D light flashing - Require ECU fault code reading near Swindon

    Hello

    We have a 1996 Toyota Hilux Surf KZN185 with an automatic gearbox. The O/D light is flashing after driving for approx 0.5 miles. The vehicle appears to be moving off in second gear instead of first. First gear can be selected manually and works fine.

    I have contacted several automatic gearbox specialist and they are all advising that the vehicles ECU fault code should be able to show what is at fault.

    Does anybody know of a garage in the Swindon area who is able to read fault codes on imported vehicles.

    If anyone else has experienced this problem, would be grateful to hear any information.

    Thank you for your assistance.

    Mergy

  • #2
    A quick check using the forums search feature turned up 13 threads when searching for "O/D Light flashing"

    These should start you off
    http://www.yotasurf.co.uk/forums/sho...light+flashing

    and
    http://www.yotasurf.co.uk/forums/sho...light+flashing

    or use the search feature to find more.
    Maurice
    Hilux Surf FAQ at www.hiluxsurf.eu

    Comment


    • #3
      O/D light flashing

      I have experience a similar problem few months ago and the O/D light flashing indicate one or all four solenoid valve inside the gearbox is faulty.

      Regards.

      Comment


      • #4
        Sounds like the fault my old surf had, no2 solenoid is going open or short circuit. The ecu picks this up and puts the gearbox into limp mode. The box will still shift manualy as you are phsyically operating the hydraulic valves that the solenoids normally operate. It shouldn't be an expensive fix (mine cost $300NZ). All this is assuming it has an A340H or A340F slush box in which case No 1 & 2 solenoids are responsible for the gearshift,

        Comment


        • #5
          make sure your knee is not tapping against the o/d button!!!! same thing happened to me. (i felt really stupid when i realised)

          Comment


          • #6
            Originally posted by markyw
            make sure your knee is not tapping against the o/d button!!!! same thing happened to me. (i felt really stupid when i realised)
            It was no. 2 solenoid. 225.00 parts and labour.

            Thanks for your help.

            Comment

            Working...
            X